1

NVIDIA EDID File missing – Linux showstopper

Posted by Thorsten on 5. Oktober 2013 in Allgemein, linux, Ubuntu, UPlanet |

Ich habe jetzt seit 2006 Linux auf dem Firmenlaptop im Einsatz und habe es bisher noch nie wirklich bereut. Klar gibt es ab und an kleinere oder mittlere Konfigurationshürden um irgendwelche Firmenvoraussetzungen erfüllen zu können aber ich hab es immer hingebogen bekommen. Jetzt bin ich seit ca. Mai allerdings auf einen absolution Showstopper (für mich) gestoßen.

Angefangen hat es im Mai als ich bei einer Onsite Schulung in Belgien einen Beamer im Präsentationsraum vorfand dessen Auflösung nicht über 800×600 konfigurierbar war. Das ist natürlich „ein wenig“ ärgerlich wenn man Morgends beim Kunde ankommt, noch 30 Minuten bis zum Präsentationsstart hat und man den Beamer nicht zum laufen bekommt.

Bei dem Kunden hatte ich Abends noch recht viel Zeit fürs Troubleshooting und ich bin mir sicher das Problem auf eine fehlende EDID Info des Beamers eingegrenzt zu haben. Hier gibts auch schon einen Bug Report der das Problem umschreibt.

Damals habe ich mit einem anderen PC arbeiten können (mit Windows klappte die höhere Auflösung wunderbar *nerv*), allerdings war ich letzte Woche bei dem gleichen Kunden mit einem anderen Beamer (anderer Präsentationsraum) noch einmal und ich hatte das identische Problem schon wieder. Meine Auflösung ließ sich auf dem Beamer (per VGA Kabel verbunden) nicht dazu übereden eine Auflösung höher als 800×600 zu präsentieren.

Diese Woche war ich bei einem anderen Kunden in Basel und hatte dort mit einem Beamer schon wieder das gleiche Problem. Hier gab es allerings keine Alternative und ich habe die Infos die es zu präsentieren gab kurz mit der 800×600 Auflösung gezeigt und dann den Beamer wieder abgeschalten.

Für mich ist dieses Problem derzeit ein absoluter Showstopper. Wenn ich mit dem Laptop auf Kundenseite nicht kurz mal an den Beamer ran kann um etwas präsentieren zu können fallsen für mich schlagartig alle Vorteile die ich mit Linux genieße unter den Tisch. Ich bin gerade wirklich frustriert und überlege wieder eine Dualboot Installation zu betreiben. Auch wenn ich mir dadurch wieder ein ungeliebtes System mit vielen „Problemchen“ auf den Laptop hole.

Mit Windows gab es bei keinem der genannten Beamer irgendein Auflösungs- oder Konfigurationsproblem. Ich bin auch hier im NVboad über negative Berichte gestolpert das es von Seiten NVIDIA auch nicht wirklich Hilfe gibt. Selbst wenn man wie hier einen NVIDIA Bug report eröffnet erhält man keine Reaktion.

Ist sonst noch jemand auf dieses Problem gestoßen? Falls jemand spontan einen Workarround hat bin ich sehr hellhörig. Allerdings ist mir das Problem bisher immer nur in Kundenumgebungen mit durchaus bekannten Beamer Modellen passiert, das macht das reproduzieren relativ schwierig.

Und nein, dort habe ich normalerweise keine Zeit mir in einer Windows Umgebung das EDID File aus der Registry zu holen, in ein File zu sichern und über die xorg.conf zur Verfügung zu stellen. Das ist kein Workarround, das ist im praktischen Alltag nicht umsetzbar.

Schlagwörter: , ,

1 Comment

  • Christoph sagt:

    Vorweg: Ich habe mit Beamern nur wenig Erfahrungen. Die von der Uni haben bei mir immer gut funktioniert, aber ich habe auch eine AMD APU/GPU und die Beamer hatten meist keine hohe Auflösung.

    Es hört sich irgendwie nach einem „Treiberproblem“ an (oder habe ich das falsch verstanden?). Hast du schon mal den freien NVIDIA Grafiktreiber probiert? Oder ist es evtl. möglich eine höhere Auflösung per randr einzustellen?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Copyright © 2009-2017 linux-voodoo.de All rights reserved.
This site is using the Desk Mess Mirrored theme, v2.4, from BuyNowShop.com.