0

SAP: ORA-00704: bootstrap process failure ORA-39700: database must be opened with UPGRADE option

Posted by Thorsten on 9. April 2015 in Allgemein, linux, SAP |

Heute lief ich in einem SAP Kundenprojekt während der SAPINST Phase „Create database“ bei einer Oracle 11.2.0.4 Installation der SAPINST in den oben genannten Fehler:

ORA-00704: bootstrap process failure
ORA-39700: database must be opened with UPGRADE option

Im sapinst_dev.log beschwerte sich der SAPINST lauthals das die Datenbank nicht mehr zur Verfügung stand:

DIAGNOSIS: Error message: ORA-01092: ORACLE instance terminated. Disconnection forced
ORA-00704: bootstrap process failure
ORA-39700: database must be opened with UPGRADE option

Das selbe stand im Oracle alert log.

Nach etwas suchen hat folgende Prozedur weiter geholfen:

Logischerweise als oraSID User

sqlplus / as sysdba
 sql>startup upgrade
 sql>@<ORACLE_HOME>/rdbms/admin/catalog.sql
 sql>@<ORACLE_HOME>/rdbms/admin/catproc.sql
 sql>shut immediate
 sql>startup

Danach lief die Datenbank wieder und der SAPINST konnte weitermachen.

 

Schlagwörter: , , ,

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Copyright © 2009-2017 linux-voodoo.de All rights reserved.
This site is using the Desk Mess Mirrored theme, v2.4, from BuyNowShop.com.