25

Synology: Video Station -> „Audio Format wird nicht unterstützt“

Posted by Thorsten on 4. März 2017 in Allgemein |

Bis vor 6 Wochen war ich Besitzer einer Synology DS211+. Wie der Name schon sagt stammte die Diskstation mit 2 Bays aus dem Jahre 2011. Lange Zeit wurde die Diskstation für OwnCloud und alle internen Dokumente/persönliche Filme/Audio und Bilder genutzt. Beim streamen von Filmen auf unterschiedliche Clients im LAN (Fernseher, Stereoanlage, iPad, iPhone, Laptop Win, MacBook) hatte ich überhaupt keine Probleme.

Anfang diesen Jahres habe ich mir eine neue Synology DS916+ zugelegt. Es bedurfte einfach mal einem Upgrade :D. Dabei bemerkte ich schnell das es gerade beim streamen von Filmen sehr oft auf den Clients, und auch sehr ärgerlich auf dem Fernseher, zum Fehler „Audio Codec wird nicht unterstützt“ kam. Diverse Videos konnten seit dem Upgrade bei mir nicht mehr abgespielt werden. Mit ein bißchen suchen fand ich heraus das es ausschließlich Videodateien mit DTS Sound betrifft.

Heute bin ich über diesen Beitrag von Nuno Horta gestolpert. Es gibt scheinbar ein 3rd Party Application welche den DTS Codec wieder zur Verfügung stellt.

Wie bekomme ich den DTS Codec wieder auf die Diskstation?

Unter diesem Link könnt ihr für eure CPU Architektur ein Zusatz Paket herunter laden (Sagt mir Bescheid wenn der Link nicht mehr funktioniert).

Ihr seid nicht sicher welche Architektur eure Diskstation hat? Schaut hier nach.

Anschließend geht ihr in eurer Diskstation in den Paketmanager oben auf den Button „Manuelle Installation“:

Hier gebt ihr euer heruntergeladenes Paket an.

Anschließend wird es installiert und sollte bei euch aktiv laufen:

Bei mir hat es noch einen reboot der Diskstation gekostet. Anschließend funktionieren auch die Videos mit DTS auf den Clients wieder *happy* 🙂

Schlagwörter: , ,

25 Comments

  • Axel sagt:

    Hallo,
    ich bin da nicht so der Experte in solchen Sachen und tu mich da lieber noch mal rückversichern.
    Ich habe ein DS 716+II und hoffe das Dies die richtige Datei ist (FFmpegWithDTS-braswell-1.0-0005)
    Ich habe dieses Problem auch mit der DS und es nervt. Entschuldige bitte wenn ich da noch mal nachharke aber wie gesagt, bin bei sowas recht unerfahren.

    mfg
    Axel

  • Thorsten sagt:

    Hi Axel,

    also wenn ich in der Liste von Synology nachschaue steht hier „Braswell“ als Architektur für deine 716+II. Das Paket müsste also eigentlich passen. Ich übernehme aber trotzdem keine Haftung 😀

    Ich meine das der Paketmanager falsche Archtitekturpakete aber auch erkennt und davor warnt diese ein zu spielen.
    Viel Erfolg

    Gruß
    Thorsten

  • Axel sagt:

    Dankt Thorsten, hat geklappt und läuft super

    Gruß
    Axel

  • Tschuege sagt:

    Vielen Dank für diese Anleitung. Ich habe mir die DS418play gekauft und konnte mit dem folgenden Paket die DTS Dateien zum laufen bringen.
    FFmpegWithDTS-x86_64-1.0-0005
    Einfach wenn einer mal unsicher sein sollte.

  • Thorsten sagt:

    Danke für deine Rückmeldung

  • rengaw75 sagt:

    Hallo,

    ich will nur DANKE sagen.
    Das ist eine super Seite mit suber Hilfe und Anleitungen.

    einfach perfekt !!!

  • Timon sagt:

    Hi,

    gibt es für die DS218play auch ein passendes Paket?
    Prozessor: rtd1296

  • Thorsten sagt:

    Hi Timon,

    gut Frage, lt. Synology hat die DS218play einen Realtek RTD1296 Chipsatz. Dafür sehe ich kein eigenes Paket.
    Ich würde es einfach mal mit „FFmpegWithDTS-x86_64-1.0-0005.spk“ probieren.
    Falls es nicht nutzbar ist sagt dir das dein DSM schon. Kaputt geht dabei aus meiner Sicht nicht.

  • Timon sagt:

    Hi Thorsten,

    danke für die schnelle Antwort. Hat aber leider nicht geklappt.
    „Dieses Paket wird auf der Plattform von DiskStation nicht unterstützt oder ist nicht kompatibel mit der aktuellen DSM-Verison.“

    🙁

  • Timon sagt:

    Okay ich hab jetzt einfach mal alle durchprobiert : D und eins hat geklappt für die DS218play mit DSM 6.1.4-15217

    FFmpegWithDTS-comcerto2k-1.0-0005.spk

    DTS Problem gelöst!:))

  • Thorsten sagt:

    Danke für die Rückmeldung!

    Gruß
    Thorsten

  • Andreas sagt:

    Hallo,
    ich habe eine DS213j. Laut der Liste hat mein NAS eine Marvell Armada 370 88F6707 CPU. Habe mir also das FFMpeg armad-1.0-0005.spk heruntergeladen und über das Paket-Zentrum installiert. Laut Anzeige läuft es auch. Trotzdem bekomme ich, trotz Neustart, beim Starten eines Video über Video-Station die Fehlermeldung: „Dieses Videoformat wird von mein Computer nicht unterstützt“. Was mach ich falsch? Oder liegt es gar nicht am FFMpeg?

  • Jochen sagt:

    Zuerst einmal danke für die Anleitung. Genau das hatte ich gesucht.
    Ich habe die DS216J, die Laut der von dir verlinkten Liste das CPU-Modell Marvell Armada 385 88F6820. Alles mit Armada im Namen konnte ich aber nicht installieren. Geklappt hat die Installation dann mit der Datei „FFmpegWithDTS-comcerto2k-1.0-0005“. Das Abspielen der Video geht aber trotzdem noch nicht.

    Hat jemand noch einen Tipp? Evtl. jemand mit dem gleichen Modell, der es zum Laufen bekommen hat?

  • zwantE sagt:

    DS214+ funzt alles wie beschrieben!

    DICKES DANKE!

  • Tarneller sagt:

    Habe DS215j: und es geht! Vielen vielen Dank. Passt perfekt. DTS geht auch bei mir wieder.

  • Alex sagt:

    Moin moin,

    ich habe mir eine DS119j gegönnt. Auf der Seite steht, dass ich das „armada37xx“ Paket habe. Auf der Seite sind drei Dateien, die mit armada beschrieben sind. Nur leider sagt meine Platte bei jedem, das es inkompatibel sei. Ich hoffe du kannst auch mir helfen?

  • Alex sagt:

    Hallo nochmal,

    habe jetzt auch alle einmal durchgetestet und die „FFmpegWithDTS-comcerto2k-1.0-0005“ hat geholfen. Ich konnte sie installieren, musste noch nen neustart der Platte machen und schon hat es funktioniert.

  • Thorsten sagt:

    Hi Alex, super das es geklappt hat. Sorry für meine späte Reaktion. Hatte deinen Post gelesen aber keine Zeit direkt zu antworten.
    Gruß Thorsten

  • Christian sagt:

    DS418play mit DSM 6. Leiderfunzt es nicht – auch nicht die …comcerto-version, die oben angeführt wurde 🙁

  • Patrick D sagt:

    Hallo habe die DS218 J welches Paket kann ich für diese nehmen. Bitte um Hilfe

  • Thorsten sagt:

    Hi Patrick,
    da mein Blogartikel ja bereits ca. 2 Jahre alt ist, ist dieser nicht mehr auf dem aktuellsten Stand.
    Unter DSM 6.X würde ich die Vorgehensweise aus diesem Artikel empfehlen: https://costigator.com/system-administration/how-to-enable-dts-support-on-synology/

    Laut Synology hast du folgende CPU: „Marvell Armada 385 88F6820“
    Siehe:
    https://www.synology.com/de-de/knowledgebase/DSM/tutorial/Compatibility_Peripherals/What_kind_of_CPU_does_my_NAS_have

    Falls die Videos mit DTS mit dem Community Paket „ffmpeg“ aus dem oben genannten Blockartikel immernoch nicht funktionieren würde ich aus dieser URL das richtige Paket für die CPU suchen und manuell einspielen. Du kannst dabei eigentlich nichts falsch machen, falls ein Modul für deine CPU nicht passt wird es abgelehnt:
    https://guillaume.smaha.net/syno/

    Gruß
    Thorsten

  • Daniel sagt:

    Welche Datei benötige ich denn für eine DS218+?

    Würde mich über eure Hilfe sehr freuen!

    Vielen Dank im Voraus!

  • Luca sagt:

    Hallo Thorsten
    ich habe eine DS216j und folgende schon installiert ohne erfolg:
    armada38x-5.2_3.1.2-2
    armada38x-6.0-3.1.2-2
    ffmpeg.v11.f15047[armada38x]
    FFmpegWithDTS-comcerto2k-1.0-0005

  • Will sagt:

    Also ich hab das jetzt mal versucht und komme nicht weiter.
    Habe die DS916+ und habe mir die Datei „FFmpegWithDTS-braswell-1.0-0005.spk“ heruntergeladen, is ja glaub ich die Richtige, oder? Hab sie installiert, dann meine DS neu gestartet und geschaut, ob der Dienst läuft. Video Station geöffnet, einen Film mit DTS-Tonspur geöffnet, wird aber nicht wiedergegeben. Hab ich etwas falsch gemacht?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Copyright © 2009-2019 linux-voodoo.de All rights reserved.
This site is using the Desk Mess Mirrored theme, v2.4, from BuyNowShop.com.